40 lines
1.2 KiB
Plaintext
40 lines
1.2 KiB
Plaintext
patches adapted from https://git.alpinelinux.org/aports/tree/main/pciutils on
|
|
2020-08-29, except for the last one (which was an adaptation from the build
|
|
script to prevent a ctags dependency).
|
|
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -2,7 +2,7 @@
|
|
# (c) 1998--2013 Martin Mares <mj@ucw.cz>
|
|
|
|
OPT=-O2
|
|
-CFLAGS=$(OPT) -Wall -W -Wno-parentheses -Wstrict-prototypes -Wmissing-prototypes
|
|
+CFLAGS=$(OPT) -Wall -W -Wno-parentheses -Wstrict-prototypes -Wmissing-prototypes -fPIC
|
|
|
|
VERSION=3.2.1
|
|
DATE=2013-11-10
|
|
--- a/lib/pread.h
|
|
+++ b/lib/pread.h
|
|
@@ -12,8 +12,8 @@
|
|
* don't define it.
|
|
*/
|
|
|
|
-#if defined(__GLIBC__) && __GLIBC__ == 2 && __GLIBC_MINOR__ > 0
|
|
-/* glibc 2.1 or newer -> pread/pwrite supported automatically */
|
|
+#if (defined(__GLIBC__) && __GLIBC__ == 2 && __GLIBC_MINOR__ > 0) || (_POSIX_VERSION >= 200809L)
|
|
+ /* glibc 2.1 or newer or posix 2008 -> pread/pwrite supported automatically */
|
|
|
|
#elif defined(i386) && defined(__GLIBC__)
|
|
/* glibc 2.0 on i386 -> call syscalls directly */
|
|
--- a/Makefile 2020-05-30 22:17:26.000000000 +0000
|
|
+++ b/Makefile 2020-08-29 16:45:39.020000000 +0000
|
|
@@ -103,7 +103,7 @@
|
|
|
|
ctags:
|
|
rm -f tags
|
|
- find . -name '*.[hc]' -exec ctags --append {} +
|
|
+# find . -name '*.[hc]' -exec ctags --append {} +
|
|
|
|
TAGS:
|
|
rm -f TAGS
|