130 lines
3.6 KiB
Plaintext
130 lines
3.6 KiB
Plaintext
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
|
|
# Maintainer: Valery Kartel <valery.kartel@gmail.com>
|
|
pkgname=weston
|
|
pkgver=9.0.0
|
|
pkgrel=0
|
|
_libname=lib$pkgname
|
|
_libdir=$_libname-${pkgver%%.*}
|
|
pkgdesc="The reference Wayland server"
|
|
url="https://wayland.freedesktop.org/"
|
|
arch="all !s390x !ppc64le"
|
|
license="MIT"
|
|
makedepends="wayland-protocols libxkbcommon-dev xkeyboard-config
|
|
libinput-dev libunwind-dev mtdev-dev libxcursor-dev glu-dev
|
|
pango-dev colord-dev libwebp-dev libva-dev dbus-dev
|
|
linux-pam-dev wayland-dev libevdev-dev libjpeg-turbo-dev
|
|
freerdp-dev lcms2-dev gstreamer-dev gst-plugins-base-dev meson
|
|
elogind-dev
|
|
"
|
|
_cms="cms-colord cms-static"
|
|
_shell="shell-desktop shell-fullscreen shell-ivi"
|
|
_client="info terminal wcap-decode"
|
|
_backend="backend-drm backend-fbdev backend-headless
|
|
backend-x11 backend-wayland backend-rdp
|
|
"
|
|
for _sub in $_cms $_shell $_client $_backend; do
|
|
subpackages="$subpackages $pkgname-$_sub:_sub"
|
|
done
|
|
subpackages="$pkgname-dev $pkgname-doc $subpackages
|
|
$pkgname-clients $_libname-desktop:_libd $_libname:libs
|
|
$pkgname-xwayland $pkgname-desktop-x11:_x11:noarch
|
|
"
|
|
source="https://wayland.freedesktop.org/releases/weston-$pkgver.tar.xz
|
|
timespec.patch
|
|
missing-fnctl_h.patch
|
|
"
|
|
# weston-launch requires suid
|
|
options="!check suid"
|
|
install="$pkgname.pre-install"
|
|
|
|
build() {
|
|
abuild-meson \
|
|
-Dlauncher-logind=true \
|
|
-Dsystemd=false \
|
|
-Dsimple-dmabuf-drm=auto \
|
|
-Dpipewire=false \
|
|
build
|
|
meson compile ${JOBS:+-j ${JOBS}} -C build
|
|
}
|
|
|
|
# Does not run through, see also:
|
|
# https://github.com/alpinelinux/aports/pull/1689
|
|
check() {
|
|
ninja -C "$builddir"/build test
|
|
}
|
|
|
|
package() {
|
|
DESTDIR="$pkgdir" ninja -C "$builddir"/build install
|
|
|
|
mkdir -p "$pkgdir"/usr/lib
|
|
mv "$pkgdir"/usr/share/pkgconfig/* "$pkgdir"/usr/lib/pkgconfig/
|
|
}
|
|
|
|
libs() {
|
|
depends="xkeyboard-config"
|
|
default_libs
|
|
}
|
|
|
|
_libd() {
|
|
pkgdesc="Desktop shells abstraction library for libweston compositors"
|
|
mkdir -p "$subpkgdir"/usr/lib
|
|
mv "$pkgdir"/usr/lib/*desktop* "$subpkgdir"/usr/lib
|
|
}
|
|
|
|
clients() {
|
|
pkgdesc="Weston example clients"
|
|
mkdir -p "$subpkgdir"/usr/bin
|
|
mv "$pkgdir"/usr/bin/$pkgname-* "$subpkgdir"/usr/bin
|
|
}
|
|
|
|
xwayland() {
|
|
pkgdesc="Wayland module to run X Clients"
|
|
mkdir -p "$subpkgdir"/usr/lib/$_libdir
|
|
mv "$pkgdir"/usr/lib/$_libdir/xwayland.so \
|
|
"$subpkgdir"/usr/lib/$_libdir
|
|
}
|
|
|
|
_x11() {
|
|
pkgdesc="Weston desktop helper pack (x11 backend)"
|
|
depends="$pkgname $pkgname-shell-desktop $pkgname-xwayland
|
|
$pkgname-backend-x11 $pkgname-terminal"
|
|
mkdir -p "$subpkgdir"
|
|
}
|
|
|
|
_sub() {
|
|
local name path
|
|
case $subpkgname in
|
|
*-cms-*)
|
|
name=${subpkgname#$pkgname-cms-}
|
|
path=/usr/lib/$pkgname
|
|
pkgdesc="Weston CMS module: $name"
|
|
name=cms-$name.so
|
|
;;
|
|
*-shell-*)
|
|
name=${subpkgname#$pkgname-shell-}
|
|
path=/usr/lib/$pkgname
|
|
pkgdesc="Weston shell: $name"
|
|
name=*$name-shell*
|
|
;;
|
|
*-backend-*)
|
|
name=${subpkgname#$pkgname-backend-}
|
|
path=/usr/lib/$_libdir
|
|
pkgdesc="Weston backend: $name"
|
|
name=$name-backend.so
|
|
grep -q cairo "$pkgdir"/$path/$name && depends="mesa-dri-swrast"
|
|
;;
|
|
*)
|
|
name=$subpkgname
|
|
path=/usr/bin
|
|
[ -x "$pkgdir"/$path/$name ] || name=${subpkgname#$pkgname-}
|
|
pkgdesc="Weston client: $name"
|
|
;;
|
|
esac
|
|
mkdir -p "$subpkgdir"/$path
|
|
mv "$pkgdir"/$path/$name "$subpkgdir"/$path
|
|
}
|
|
|
|
sha512sums="ccc263f8279b7b23e5c593b4a8a023de2c3dc178b1b8d6593599171770bcfe97608de9fcb77aa1cab39255451d289d323e51c317dae190c7641282e085b84f90 weston-9.0.0.tar.xz
|
|
3e596af4bf0a6b06a5d28376043db111fe1c161ead04501fa6d2c667b5a21889cca3354d1bdc4ac794841bef68ed5e1a7a84e44e7d510e947e3673195706caed timespec.patch
|
|
57c1475a7a1593e26d4fae37a3cc391b43b8ec03ecf0a9da9024b0e5660565cab929bb38520bb51077f6a37a9547448b38655c1e3b9ed8237eefe81a650d5be3 missing-fnctl_h.patch"
|