Browse Source

Rename AC_PROG_LD* macros to PGAC_PROG_LD*. This avoids clashes with the

macros provided by the real libtool, when other packages borrow some macros
from PostgreSQL, as in the case of the ODBC driver.
REL8_0_STABLE
Peter Eisentraut 18 years ago
parent
commit
d0c1bbdcc6
  1. 8
      config/libtool.m4
  2. 4
      configure.in

8
config/libtool.m4 vendored

@ -28,8 +28,8 @@
# ... bunch of stuff removed here ...
# AC_PROG_LD - find the path to the GNU or non-GNU linker
AC_DEFUN([AC_PROG_LD],
# PGAC_PROG_LD - find the path to the GNU or non-GNU linker
AC_DEFUN([PGAC_PROG_LD],
[AC_ARG_WITH(gnu-ld,
[ --with-gnu-ld assume the C compiler uses GNU ld [[default=no]]],
test "$withval" = no || with_gnu_ld=yes, with_gnu_ld=no)
@ -102,10 +102,10 @@ else
AC_MSG_RESULT(no)
fi
test -z "$LD" && AC_MSG_ERROR([no acceptable ld found in \$PATH])
AC_PROG_LD_GNU
PGAC_PROG_LD_GNU
])
AC_DEFUN([AC_PROG_LD_GNU],
AC_DEFUN([PGAC_PROG_LD_GNU],
[AC_CACHE_CHECK([if the linker ($LD) is GNU ld], ac_cv_prog_gnu_ld,
[# I'd rather use --version here, but apparently some GNU ld's only accept -v.
if $LD -v 2>&1 </dev/null | egrep '(GNU|with BFD)' 1>&5; then

4
configure.in

@ -1,5 +1,5 @@
dnl Process this file with autoconf to produce a configure script.
dnl $PostgreSQL: pgsql/configure.in,v 1.367 2004/07/14 17:55:09 petere Exp $
dnl $PostgreSQL: pgsql/configure.in,v 1.368 2004/07/17 18:53:56 petere Exp $
dnl
dnl Developers, please strive to achieve this order:
dnl
@ -525,7 +525,7 @@ AC_MSG_NOTICE([using LDFLAGS=$LDFLAGS])
AC_PROG_AWK
PGAC_PATH_FLEX
AC_PROG_LN_S
AC_PROG_LD
PGAC_PROG_LD
AC_SUBST(LD)
AC_SUBST(with_gnu_ld)
case $host_os in sysv5*)

Loading…
Cancel
Save